HELP NEEDED - GPU fan spinning but no display on monitor (Part 2)
Written by: masWiK - 09:09 Jun-23-2016

So welcome to the sequel of my previous blog. This is kinda the update of my PC, and no my PC still can't work "together", and yes it is getting weirder. I'm sorry if it's a bit longer, but if you want to stick to the end, you are more than welcome :)

Last time I mentioned that I had done most of my fellow GDers' suggestion; clean my PC, change cables, connectors, etc. But still my GPU didn't post any pic on the monitor, I did try to connect it to my TV (using HDMI) but gave no result either.

And I thought my GPU is dead, so I ripped it apart, cleaned it, and changed the thermal paste (final tribute for it) and called it a day. Long story short, my friend suggested me to bring my GPU to a repair shop, see if it's really dead or just playing tricks with me. At that moment I don't think my PC is broken cuz I can use my Geforce 210 just flawless with it.

So I brought my GPU to repair shop, get checked by them AND it ran perfectly on their test bench. They only had to reboot the system once to made it run. I was like WAT THE HECK DUDE! then they let my GPU run Valley Benchmark for 20 mins and everything was looking normal, with lower load temp (dat final tribute paid off eventually) almost 5°C difference. Then I brought it back home hoping I could run it on my PC.

And no, still didn't work, Yeah :/ I even tried to switch to my old PSU to see if there's any different. But nope, nothing happened. So I brought my whole PC to repair shop, to see if they can do something.

Well they tested my PC with GTX 770, it ran okay. They tested my GPU with their test bench, it ran okay. They tested my PC with my GPU, it was not okay :/ They tried to update the mobo BIOS but still no display with the GPU. So I left my PC with them to work around the problem. The next day, still they couldn't fix it :( I mean what are the odds? It is so freaking weird. If you guys have the answer, just let me know in the comment below.

A bit out of topic seems like I won't spend more money on my PC for now. I did mention to upgrade it to an i7, but I change my mind since I'm going to college very soon. So I decided to buy laptop cuz if I upgraded my PC and bring it with me, I can't play games if I have to go home, so I have to choose (fuck me right lol) Something with GTX 970m perhaps. End of the blog fella (Uhh finally) you can get the cookies now

enjoy :)

Followers 409
GD Rank 8
Reputation 20
Total Blog Views: 4,788
Title Hits Date
HELP NEEDED - GPU fan spinning but no display on monitor (Part 2) 1814 Jun-23-2016
HELP NEEDED - GPU fan spinning but no display on monitor 2974 Feb-23-2016
View all by this member View all

Login or Register to join the debate

Rep
2
Offline
17:04 Jun-23-2016

Could pls say the exact specs of your pc?

0
Rep
20
Offline
06:46 Jun-24-2016

you can check it on my profile, I think that's all I got and they're exactly the same as I have. If you wanna know a specific component feel free to ask

0
Rep
2
Offline
08:35 Jun-25-2016

Well, there are typical procedures to take.
1-try another psu
2-update bios
3-make sure you are using the pcie 3.0 x16 slot, or try another slot(pcie 2.0)
4-switch the ram sticks
5-try different connections and cables(dvi,hdmi)

0
Rep
20
Offline
09:24 Jun-25-2016

  1. done, but nothing happen

  2. upgrade it, downgrade it, still the same (not done by me, the repair shop did it)

  3. my mobo only has 1 PCIe x16 slot :( the 2.0 one

  4. probably gonna try that, but I'll just do the elimination procedure since I don't have any RAM stick left

  5. I tried with vga cable (via adaptor) and with HDMI cable but still can't work (both on my monitor and my TV)

0
Rep
1,041
Offline
senior admin badge
09:11 Jun-23-2016

you sure you ain't plugging the monitor cable into integrated gpu video output? just to make sure

0
Rep
20
Offline
09:13 Jun-23-2016

Dude pls lol

0
Rep
45
Offline
admin approved badge
16:00 Jun-24-2016

Did you remember to turn the computer on?

0
Rep
20
Offline
06:44 Jun-25-2016

I did remember to turn the heat to 180°C and warmed it for 30 mins. Should I put gasoline or diesel in it?

0
Rep
45
Offline
admin approved badge
23:49 Jun-25-2016

maybe it's your PSU

0