Overlord: Fellowship of Evil GPU Analysis
Comparing Overlord: Fellowship of Evil PC system requirements to all GPUs shows that Overlord: Fellowship of Evil is going to need a graphics card that is capable of OpenGL 4.3.

Overlord: Fellowship of Evil makes use of DX 11.00 so a GPU with that capability could benefit from enhanced visuals.

To get the best visual graphical experience on Overlord: Fellowship of Evil, aim to have a GPU that has at least 2GB GPU RAM.

Medium level graphics cards currently available today, will probably allow you to play Overlord: Fellowship of Evil

We are advised that 10 year old graphics cards should be able to run Overlord: Fellowship of Evil, but there could be a few exceptions to this rule.

Note that most games do not officially support laptop graphics cards, but nowadays many laptop graphics solutions are capable of running modern games. Whether desktop graphics cards or laptop, try searching for your graphics card to compare against the Overlord: Fellowship of Evil graphics card requirements chart below.