Marvel Heroes 2015 - Kitty Pryde Pack Compatible CPUs

Processors (CPU) that meet:
Marvel Heroes 2015 - Kitty Pryde Pack minimum system requirements
Intel - Desktop CPU
Intel - Laptop CPU
AMD - Desktop CPU