Marvel Heroes 2015 - Kitty Pryde Pack Compatible Graphics Cards

Graphics Cards (GPU) that meet:
Marvel Heroes 2015 - Kitty Pryde Pack minimum system requirements
Nvidia - Desktop GPU