Marvel Heroes 2015 - Kitty Pryde Pack GPU Analysis
Comparing Marvel Heroes 2015 - Kitty Pryde Pack PC system requirements to all GPUs shows that Marvel Heroes 2015 - Kitty Pryde Pack is going to need a graphics card that is capable of OpenGL 4.2.

To get the best visual graphical experience on Marvel Heroes 2015 - Kitty Pryde Pack, aim to have a GPU that has at least 2GB GPU RAM.

Most bottom end graphics cards currently available today, will probably allow you to play Marvel Heroes 2015 - Kitty Pryde Pack

We are advised that 9 year old graphics cards should be able to run Marvel Heroes 2015 - Kitty Pryde Pack, but there could be a few exceptions to this rule.

Note that most games do not officially support laptop graphics cards, but nowadays many laptop graphics solutions are capable of running modern games. Whether desktop graphics cards or laptop, try searching for your graphics card to compare against the Marvel Heroes 2015 - Kitty Pryde Pack graphics card requirements chart below.