Fringes of the Empire packshot image
Fringes of the Empire is a hybrid platformer and top-down classic retrogame reimagined, with modding features and lots of cool guns and explosions.
Fringes of the Empire GPU Performance Comparison Graph

Fringes of the Empire GPU Analysis
Comparing Fringes of the Empire PC system requirements to all GPUs shows that Fringes of the Empire is going to need a graphics card that is capable of DX 9 or OpenGL 4.1.

Fringes of the Empire makes use of DX11.00 so a GPU with that capability could benefit from enhanced visuals.

To get the best visual graphical experience on Fringes of the Empire, aim to have a GPU that has at least 1.024 GB GPU RAM.

Most bottom end graphics cards currently available today, will probably allow you to play Fringes of the Empire

We are advised that 10 year old graphics cards should be able to run Fringes of the Empire , but there could be a few exceptions to this rule.

Note that most games do not officially support laptop graphics cards, but nowadays many laptop graphics solutions are capable of running modern games. Whether desktop graphics cards or laptop, try searching for your graphics card to compare against the Fringes of the Empire graphics card requirements chart below.